Login

@ScottyKilmer,
Hey Scotty,I have a concern about my transmission on my 2012 Mitsubishi Lancer Sportback GT? I have 84,000 miles and I just did a engine swap, my car came equipped with a Jatco CVT transmission.I recently ended having issues where it would slip and rev and accelerate erratic but suddenly lose power? I would noticed from 0 -20 mph it would shake and would slow down and then the car won't accelerate or rev passed 1000 rpm? It's not over heating or even have any transmission codes coming out.for me to move the car again I would have to turn off the car and turn it back on for the throttle to respond as well as the transmission only abruptly then it would slow down and stop and won't accelerate again? Also it would shake and hesitate to accelerate. What could it be? Also my car does have a p0171 code,would that cause a problem for it to accelerate?

those trannys stink, do not buy another one. It's slipping and revving, and that has nothing to do with 171 code. Get rid of it or spend MANY thousands on the CVT

Hey Scotty thanks for replying back to me.unfortunately I cannot get rid of the car because of sentimental values of the car,but I found good news! So I found out the Transmission was not the problem at all. So I had to run it with a bigger scan tool from my local mechanic and it pulled out,P1590.So I thought incorrectly about what I was trying to explain so there is resistance for the car to accelerate,so my mechanic told me it's possible the TCM is malfunctioning. I am planning to buy the tcm but I wanted to get your idea about what could cause a problem to have the code P1590?

Stories