Howdy Scotty. I recently had a P0011 code on my 2006 F150 5.4 triton engine with about 123,000…

Howdy Scotty. I recently had a P0011 code on my 2006 F150 5.4 triton engine with about 123,000 miles). The truck started acting really sluggish on take off. I cleared the code and changed the oil and filter (It wasn't due for a change for another month/2,000 miles.) Everything looked normal and I let the truck come to operating temp, test drove it twice and the code did not reappear. About three weeks prior to the P0011 code I had to change out the PCM due to a bad high-side cht temp circuit (kept getting a P128a code) Plugs and coils were also changed With the PCM. (Plugs were over due) My question, how Likely is it that dirty oil caused a P0011 code and should I continue to investigate the cvt components if the code does not come back.

dirty oil often causes that code, I would also flush the engine oil before the next change with K and W engine flush

1
1

Thank you! You are awesome and I'm greatful to you for all the time and info you give. Plus your videos are entertaining as heck!

Well the code came back so I'm going to replace the vct solenoids on both banks with motorcraft parts. Any tips, warnings, or advice on changing these?

I replaced both vct solenoids with motor craft oem parts. Code keeps coming back after driving about a 1/2 hour once it's warm. Power is really good when cold but after the code kicks in it's sluggish especially on take off. Should I flush the engine? Any advice on next steps. (Also, no stalling, stuttering and idle is smooth just looses power when warm) thanks for any advice you can give.

false