Login

Hi a question 1985 Ford 5.0 cfi federal emissions egr problem codes 31 32 33 34 egr sensor out of range range to low to high sensor not reading so I changed the sensor 3 brands were made in China so I got an original motorcraft cx863 sensor that was made in Mexico n the motorcraft one was the only one that removed the codes but I still had an egr problem to much vacuum on acceleration n holding a load all the egr vacuum solenoids were working as they should so I got an original federal motorcraft e5pe-9h473-c4a egr valve n still a problem not opening n closing fast enough so I then got an original motorcraft California emissions e45e-9h473-a2a egr valve n this seems to be working OK but not as good as my other car that I had to do this to I have 5 1985 5.0 cfi fords that are now getting this egr problem so do I change them to California emissions or am I missing something every service person I asked up here said its old so just remove the egr vacuum it worked on 1 car but the other then got the timing ping on a load so I had to fix it have you ever come into this egr problem with Ford 5.0 cfi 1983-1985 if you can let me know what you think thanks

you must be in california where testing is insane. Here in texas, that old of an engine is not pollution tested and we would just remove all that crap and they run better that way. If you do need it inspected for that, well, your solution seems fine to use the california parts

Thankyou for getting back to me I live in new York city I did disconnect the egr system but the car then had a bad timing ping if I lowered the timing one notch the ping was OK but the car was to sluggish so I had go back n reconnect the egr system also in the winter with the egr system disconnected in the morning it would floor n hard to start

Stories