Hey scotty, I watch you every day! :) I have a 2007 chevy silverado 1500 z71 4.8lt 48 270k on it.…

Hey scotty, I watch you every day! :) I have a 2007 chevy silverado 1500 z71 4.8lt 48 270k on it. Has fairly new spark plugs, has new MAS and new fuel pump. I cant figure out why i get a rough idol only first start of the day when cold. And loss of power jerking motion when I pull out of my driveway but goes away right away. after the first block of driving. when driving and i have no issues at all with shifting etc. Its a loss of power with fuel? A misfire? A intake manfold leak? Gasket issues?Its the new model truck and has brand new fuel filter and pump? Any help would be apprechiated, and thanks for helping others! :)

try this video to make it run better, often works https://www.youtube.com/watch?v=NWCKvU2FmDc

Thanks scotty I did the throttle body and MAS already thats why I was asking what else it could be. I actually replaced it lol:P Any ideas?

Look for vacuum leaks and perhaps think about replacing the MAF with an AC Delco unit for happiest result.

thanks for the reply. The MAS has been replaced. I have to check for leaks though I may take it to the shop to have a diagnosis before I load up the parts cannon. Was going to go in and do the intake gaskets, knock sensors, regulator, spark plugs and wires and if that doesnt solve it im going to assume it only does it first start of the day because its transmission and it heat seals itself :(. I have a loss of power first start and first few feet every day then it starts to idol right and work proper after that.

false